it-swarm-es.com

apt-get "Paquetes rotos"

Al instalar python-dev:

Sudo apt-get install python-dev

Estoy teniendo el siguiente error:

The following packages have unmet dependencies:
python2.7-dev : Depends: python2.7 (= 2.7.3-0ubuntu3) but 2.7.3-0ubuntu3.1 is to be installed
                Depends: libpython2.7 (= 2.7.3-0ubuntu3) but 2.7.3-0ubuntu3.1 is to be installed
E: Unable to correct problems, you have held broken packages.

Ya tengo python2.7 y libpython2.7 instalados. No entiendo "0ubuntu3" y "0ubuntu3.1" significa en el error.

Estoy en Ubuntu 12.04. He intentado apt-get update, apt-get upgrade varias veces. He intentado buscar en Google el problema, pero no puedo encontrar ninguna solución. No quiero autoremove python, va a eliminar 300MB de cosas, así que supongo que más de una cosa dejará de funcionar.

Desde entonces, reinstalé Ubuntu 12.04 y prácticamente no instalé nada después de eso, tampoco actualizaciones de seguridad, etc. Esta vez, python-dev y libboost-dev se instalaron sin problemas. Pero estoy enfrentando el mismo problema con freeglut3-dev:

The following packages have unmet dependencies:
freeglut3-dev : Depends: libgl1-mesa-dev but it is not going to be installed or
                      libgl-dev
                Depends: libglu1-mesa-dev but it is not going to be installed or
                      libglu-dev
E: Unable to correct problems, you have held broken packages.

Los comentarios que he recibido hasta ahora sugieren que debería estar relacionado con el administrador de paquetes. ¿Alguien ha enfrentado este problema? ¿Puede alguien ayudar, por favor?

Gracias

3
vegeta

Por favor, intente usar el

apt-get -f install

mando. Debe instalar todas las dependencias que faltan.

2
Guardian