it-swarm-es.com

Ubuntu 12.04 detecta el controlador del portátil como vmware

Compré el portátil Samsung N100 ayer. Instalé ubuntu 12.04 (solo sistema operativo). Después de instalarlo con éxito, descubrí que unity 3D no funciona. Ejecute jocky-3D para obtener un controlador adicional. Encontré dos controladores en la lista y los instalé.

drm driver for the intel GMA500
intel Cedarview graphics driver

Después de reiniciar, el aspecto visual se ve bien pero la unidad 3D aún no se cargó. la configuración del sistema vuelve

Gallium 0.4 on llvmpipe (LLVM 0x300)

Luego realicé la prueba de la unidad.

PVRDRIInitPVR2D: PVR2D device index (0) **OpenGL vendor string:   VMware, Inc.**
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
OpenGL version string:  2.1 Mesa 8.0.4

Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

Una noticia sorprendente es que proveedor de OpenGL cadena devuelve VMware, Inc. ¿Qué significa esto? ¿Ubuntu detecta mi computadora portátil como cliente VMware?

Información adicional:

server glx version string: 1.4
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
OpenGL version string: 2.1 Mesa 8.0.4
OpenGL shading language version string: 1.20

VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 0b) (prog-if 00 [VGA controller])
3
shantanu

Estoy ejecutando kubuntu 12.04 en una vista de cedro atom 2600 netbook. Hay una opción en la configuración de kde para seleccionar opengl o xrender. Si selecciona opengl, cambiará a xrender.

Yo estoy convencido de que los paquetes de controladores cedarview no son compatibles con opengl. Período. No creo que puedas obtener un rendimiento gráfico completo si esa gpu en Linux. Es de código cerrado. Lo uso en una netbook, así que no me importa personalmente, aunque puedo ver cómo podrían hacerlo otros.

Probé las versiones alfa 2 y beta de kubuntu 13.04. Eso tiene los controladores incorporados en el kernel (kernel de Linux> = 3.7). No se necesitan descargas de controladores, pero la misma situación. Sin capacidad de apertura.

Lo que también significa que no podrá usar 12.10 o versiones posteriores de la unidad. Dejaron caer la opción 2D.

Puede que esto no sea lo que querrá escuchar, pero simplemente instalaría xubuntu o kubuntu. KDE (kubuntu) usa una memoria similar a la unidad y es más rápida y mucho más potente. Encuentro Unity/compiz/gnome3 lento y con errores de todos modos. Nunca lo usaría en mi computadora portátil i3, que es mucho más potente que mi netbook.

3
user138156