it-swarm-es.com

Demasiado ruido al grabar en 12.10

Estoy usando Kubuntu 12.10 con Backports habilitado y recibo demasiado ruido al hacer screencasts en Kazam u otras aplicaciones como Recordmydesktop, también aparece ruido al grabar la cámara web con Kamoso.

Tengo un Acel Travellmate 5760z que usa un i3 con una tarjeta gráfica Intel HD 3000, estoy usando la cámara web y el micrófono de la computadora portátil, ¿puede ser un problema de controladores? Esto comenzó a suceder hace 1 o 2 semanas, ¿quizás alguna actualización salió mal?

PD: Perdón por mi mal inglés y gracias por tomarse el tiempo.

[ACTUALIZACIÓN] Hola, probé Kubuntu 13.04 (Raring Ringtail) y grabé un video con Kamoso (que graba la cámara web) y el audio estaba bien, no apareció ruido, por lo que parece que esto se ha solucionado para RaringRingtail, tal vez una versión más nueva de Un paquete resuelto eso. Pero todavía tengo ese problema en 12.10.

[SOLUCIONADO] Primero, siga los pasos en la primera respuesta proporcionada por NikTh (tal vez necesite verificar la fuente), luego instalé "pavucontrol" y "alsamixergui", y mientras hacía la grabación de sonido seguí cambiando los valores hasta que obtuve el combinación que hizo que mi grabación de sonido funcionara genial.

2
Thundlayr

Puede probar una solución alternativa y ver si obtiene mejores grabaciones.

Primero abra una terminal (CTRL + ALT + T) y aplique el siguiente comando

arecord --list-devices 

El resultado debería ser algo como esto

**** List of CAPTURE Hardware Devices ****
card 0: MID [HDA Intel MID], device 0: ALC272X Analog [ALC272X Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Arriba están mis resultados. Entonces mi tarjeta de sonido es hw: 0,0

Ahora aplique el siguiente comando

arecord -f dat -r 60000 -D hw:0,0 -d 5 test.wav

y preste atención a un resultado específico, aquí están mis resultados

Recording WAVE 'test.wav' : Signed 16 bit Little Endian, Rate 60000 Hz, Stereo
Warning: rate is not accurate (requested = 60000Hz, got = 48000Hz)
         please, try the plug plugin

Estamos interesados ​​en el got = 48000 aquí. El número puede diferir.

Ahora vea cuánto es la frecuencia de muestreo en pulseaudio

cat /etc/Pulse/daemon.conf|grep sample-rate

Resultado

; default-sample-rate = 44100

significa que no es lo apropiado.

Cámbielo con el siguiente comando al valor apropiado (en este caso, 48000)

Sudo sed 's/; default-sample-rate = 44100/default-sample-rate = 48000/g' -i /etc/Pulse/daemon.conf 

Ahora ve de nuevo el resultado

cat /etc/Pulse/daemon.conf|grep sample-rate

debiera ser

default-sample-rate = 48000

Reinicie su PC y vuelva a probar la grabación de sonido.

Fuente

Si la solución anterior no soluciona el problema, entonces tal vez debería considerar comprar un micrófono USB externo

OR

use un programa como audacity para eliminar el ruido de fondo. Aquí hay un PPA para audacity - Ubunt

4
NickTux

Lo resolví Primero, siga los pasos en la primera respuesta proporcionada por NikTh (tal vez deba verificar la fuente), luego instalé "pavucontrol" y "alsamixergui", y mientras hacía la grabación de sonido seguí cambiando los valores hasta que obtuve la combinación que hizo mi grabación de sonido funciona muy bien.

Espero que esto ayude, ¡Gracias por todo!

3
Thundlayr

Aquí hay otra posible solución:

  1. Abra Kazam y vaya a Archivo -> Preferencias
  2. En General, verifique qué se enumera como la fuente para "Micrófono".

En mi caso, estaba usando el micrófono de mi cámara web como fuente predeterminada, por lo que recibí todo el ruido. Lo cambié a "Audio estéreo analógico incorporado" y el ruido desapareció.

1
Tim Nafziger