it-swarm-es.com

¿Por qué Ubuntu 12.10 wifi sigue desconectándose?

Estoy usando Ubuntu 12.10 en una Macbook Pro con tarjeta de red inalámbrica Broadcom BCM4331. He instalado el controlador b43 para poder usar la tarjeta inalámbrica. Sin embargo, la conexión inalámbrica se desconecta cada pocos minutos (solo al azar, a veces después de media hora, a veces después de 10 o 15 minutos ...).

Puedo ver esto en el icono del administrador de red. Y se vuelve a conectar automáticamente. Esto sucede más cuando estoy conectado a WPA 2 y WPA2 Enterprise, pero también a veces cuando también estoy conectado a redes inalámbricas no seguras.

Encuentre la salida de una serie de comandos a continuación. Si necesita más información, hágamelo saber. Agradezco cualquier ayuda por adelantado.

Sudo ifconfig -a

lo        Link encap:Lokale Schleife  
      inet Adresse:127.0.0.1  Maske:255.0.0.0
      inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
      UP LOOPBACK RUNNING  MTU:16436  Metrik:1
      RX packets:712 errors:0 dropped:0 overruns:0 frame:0
      TX packets:712 errors:0 dropped:0 overruns:0 carrier:0
      Kollisionen:0 Sendewarteschlangenlänge:0 
      RX-Bytes:56910 (56.9 KB)  TX-Bytes:56910 (56.9 KB)

wlan0     Link encap:Ethernet  Hardware Adresse 14:10:9f:db:d6:7b  
      inet Adresse:192.168.2.103  Bcast:192.168.2.255  Maske:255.255.255.0
      inet6-Adresse: fe80::1610:9fff:fedb:d67b/64 Gültigkeitsbereich:Verbindung
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
      RX packets:411 errors:0 dropped:0 overruns:0 frame:0
      TX packets:468 errors:0 dropped:0 overruns:0 carrier:0
      Kollisionen:0 Sendewarteschlangenlänge:1000 
      RX-Bytes:119863 (119.8 KB)  TX-Bytes:81782 (81.7 KB)


lspci | grep Broadcom

03:00.0 Ethernet controller: Broadcom Corporation Device 16a3 (rev 10)
03:00.1 SD Host controller: Broadcom Corporation NetXtreme BCM57765 Memory Card Reader (rev 10)
04:00.0 Network controller: Broadcom Corporation BCM4331 802.11a/b/g/n (rev 02)

modprobe -l | grep b43

updates/cw-3.6/b43legacy.ko
updates/cw-3.6/b43.ko

modprobe -l | grep bcm

kernel/drivers/usb/Host/bcma-hcd.ko
kernel/drivers/input/mouse/bcm5974.ko
kernel/drivers/media/dvb/frontends/bcm3510.ko
kernel/drivers/staging/bcm/bcm_wimax.ko
kernel/net/can/can-bcm.ko
updates/cw-3.6/bcma.ko
updates/cw-3.6/bcm203x.ko

cat /etc/network/interfaces
auto lo iface lo inet loopback

Por cierto, no sé si esto es extraño o no, pero en el registro del sistema (/ var/log/syslog) cada pocos minutos veo la autenticación de wpa_supplicant de esta manera:

NetworkManager[970]: <info> (wlan0): supplicant interface state: completed -> disconnected  
NetworkManager[970]: <info> (wlan0): supplicant interface state: disconnected -> scanning  
wpa_supplicant[1368]: wlan0: SME: Trying to authenticate with 20:2b:c1:50:0e:76 (SSID='foo' freq=2442 MHz)
[ 365.771706] wlan0: authenticate with 20:2b:c1:50:0e:76  
NetworkManager[970]: <info> (wlan0): supplicant interface state: scanning -> authenticating  
7
user140838

Resolví mi problema instalando Ubuntu 13.04 (compilación diaria, 20 de marzo). Ahora, estoy escribiendo esta respuesta en Ubuntu 13.04. El problema inalámbrico se resuelve por completo. Otro hardware está funcionando perfectamente bien.

2
user140838