it-swarm-es.com

Estoy usando Ubuntu 16.04 y no hay fglrx!

Estoy usando Ubuntu 16.04 y no hay fglrx! ¿Que pasó?

16
digitalcrow

Para iniciar Steam sin fglrx, escribe esto en Terminal:

LD_PRELOAD='/usr/$LIB/libstdc++.so.6' DISPLAY=:0 Steam

La terminal tiene que estar activa, para juegos pequeños (Stellaris por mi cuenta) es practicable.

8
Fream

El historial de publicación en Launchpad indica que el paquete se ha eliminado para 16.04:

Removed from disk on 2016-03-03.
Removal requested on 2016-03-03.
Deleted on 2016-03-03 by Martin Pitt
(tjaalton) there will not be updates any more, incompatible with new X.org ABI, free driver is good enough now

Podría publicar un error en Launchpad si considera que el controlador de código abierto no es lo suficientemente bueno.

El Notas de la versión para 16.04 tiene más información:

fglrx

El controlador fglrx ahora está en desuso en 16.04, y recomendamos sus alternativas de código abierto (radeon y amdgpu). AMD puso mucho trabajo en los controladores, y retrocedimos el código del kernel de Linux 4.5 para proporcionar una mejor experiencia.

Al actualizar a Ubuntu 16.04 desde una versión anterior, se eliminarán tanto el controlador fglrx como el xorg.conf, de modo que el sistema esté configurado para usar el controlador amdgpu o el controlador radeon (dependiendo del hardware disponible).

En na discusión de la lista de correo , se sugiere que las personas que realmente necesitan el controlador fglrx tengan que continuar usando 14.04 hasta que el controlador de código abierto mejore:

AMD dejó de admitir su controlador de video fglrx blob patentado, por lo que no se puede incluir en 16.04 LTS. La última versión que AMD hizo no se puede usar porque es incompatible con el nuevo servidor de visualización x.org. La mayoría de las personas podrán usar el controlador de video AMD de código abierto, pero hay algunas aplicaciones (ciertos juegos intensivos en gráficos, minería de bitcoins) para las cuales es inadecuado. Las personas que confían en tales aplicaciones pueden optar por permanecer en 14.04 LTS hasta que el soporte adecuado llegue a los controladores de video AMD de código abierto.

Relacionado:

26
muru