it-swarm-es.com

¿Se quedará Drupal 6 en un estado seguro después de que deje de ser compatible?

Creé una interfaz de base de datos personalizada usando Drupal 6 + Vistas + CCK que funciona muy bien para mi empresa y recientemente tuve que migrarlo a otro servidor.

Pensé "Hey, ¿por qué no instalar Drupal 7 y luego volcar la base de datos en él: entonces puedo actualizar Drupal) a la última versión mientras migramos! "

Eso resultó ser una mala idea. Drupal 7 no parece tener la menor idea de qué hacer con la información de base de datos que le di. Y la guía de actualización me parece muy lenta, en este momento.

Entonces mi pregunta es: ¿quedará Drupal 6 en un estado seguro después de que deje de ser compatible? ¿O la plataforma se volverá obsoleta y vulnerable, lo que me obligará a una actualización aún más masiva?

8
Garrett

Creo que hasta que algunos de los principales módulos contribuidos, como Views, tengan módulos Drupal7 que sean estables y no alfa, beta, creo que drupal6 se utilizará durante algún tiempo.

Estoy seguro de que drupal6 será compatible en los próximos años, ya que hay MUCHOS sitios de drupal6 por ahí.

Entonces la respuesta es No, NO TIENES que actualizar.

8
Camsoft

Una vez que sale Drupal 8 sale, Drupal 6 se marcará "fin de vida": el equipo de seguridad Drupal) se detendrá trabajando en ello y las versiones de seguridad oficiales no saldrán a la luz. Si surgen nuevas vulnerabilidades, tendrá que parchearlo usted mismo. Por lo tanto, es realmente beneficioso actualizar en ese momento.

Pero las rutas de actualización para Drupal son de la versión anterior a la versión actual: es decir, se proporciona una ruta de actualización desde la última versión de Drupal 6 a = Drupal 7, y se proporcionará una ruta de actualización desde Drupal 7 a Drupal 8.

No habrá una ruta de actualización para Drupal 6 a Drupal 8: si no desea reconstruir su sitio desde cero cuando Drupal 8 sale, primero deberá actualizar su Drupal 6 sitio a Drupal 7, luego actualizar a Drupal 8.

Por lo tanto, realmente se trata de economía y planificación a largo plazo. Drupal 6 será compatible hasta Drupal 8, pero cuando Drupal 8 salga en un par de años, ¿ ¿tiene la oportunidad de reescribir el sitio? Si no, debería planear actualizar a Drupal 7 en algún momento en el futuro.

15
user7

Siempre hay 2 versiones de Drupal compatibles al mismo tiempo. Entonces cuando Drupal 8 será lanzado, Drupal 6) quedará sin soporte. Queda algo de tiempo hasta que eso suceda, para que no tenga que darse prisa.

Si suficientes personas están dispuestas a continuar parcheando errores de seguridad, puede continuar usándolo de manera segura incluso si ya no es oficialmente compatible. Cualquiera que quiera puede continuar apoyando Drupal 6 con parches de seguridad indefinidamente, la pregunta es si suficientes personas están interesadas en hacerlo. No contaría con Drupal = 6 sigue siendo compatible después del lanzamiento oficial de Drupal 8.

4
Mad Scientist

Su problema original es que no desea pasar una gran cantidad de tiempo actualizando su sitio; puedo entenderlo bien, pero definitivamente recomendaría realizar la actualización. Un par de razones:

  • Tarde o temprano tendrá que actualizar porque Drupal 6 se acerca final de la vida .
  • Si está trabajando con sitios Drupal), se beneficiará enormemente si aprende a hacer una actualización importante. Muchas personas como yo comenzaron con Drupal 6 , así que esta es la primera actualización que deberíamos poder aplicar: es un conocimiento valioso.
  • Puede "alterar" el proceso de actualización escrito en el Manual - nobody mencionó que debe hacer que en una tarde, por ejemplo ... Si fuera usted, pasaría varias horas preparando, revisando módulos y temas, revisando el núcleo, etc. y al día siguiente continuaría con la actualización en Un entorno de prueba. De esta manera puedes tener un poco más de comodidad. Lo principal es, tomar notas de todo . Es mejor tener cada clic documentado (lo que sería una locura) que tener ¡nada anotado. ¡Intenta disfrutar haciendo esto, el sitio actualizado será mejor que nunca!

Y recuerde, tenemos una gran comunidad con mucha energía y apoyo, así que hable sobre lo que hace, escriba una publicación de blog o algo - alguien lo hará beneficiarse mucho, tal vez incluso usted.

2
Scorchio

Aproximadamente 5 años después de que se hizo esta pregunta, aquí hay otra respuesta basada en lo que sabemos hoy ...

¿Se quedará Drupal 6 en un estado seguro, el día que no sea compatible?

Se ha anunciado que Drupal 6 finalizará el 24 de febrero de 2016, como se detalla en Anuncio de final de la vida de Drupal 6 (*) . Entonces, a menos que tome algunas medidas apropiadas, los sitios que seguirán utilizando Drupal 6 después de esa fecha corren el riesgo de volverse inseguros.

Sin embargo, mientras tanto, el módulo myDropWizard se ha lanzado ... para D6 ... todavía , y solo !!!. Consulte " ¿Cómo obtener información precisa sobre las actualizaciones de seguridad disponibles después del final de la vida útil? " para obtener más detalles al respecto.

¿O la plataforma se volverá obsoleta y vulnerable, forzándome a una actualización aún más masiva?

Para situaciones en las que " actualizar un sitio D6 no es una opción ", una alternativa posible es Comprar = Drupal 6 Soporte a largo plazo (LTS) de uno de los proveedores " oficial " . Además, hay parece ser el proyecto D6LTS . Para obtener más detalles al respecto, consulte la respuesta a ¿Cómo proceder con un sitio D6 después del 24 de febrero de 2016 cuando D6 es el final de la vida? =.

Para aquellos que se preguntan " ¿Cuántas reportadas Drupal 6 instalaciones nos quedan? ", verifique el Estadísticas de uso para = Drupal core (sobre D5, D6, D7, D8) ... A partir del 31 de enero de 2016, parece que solo hay " "Queden aproximadamente 110K sitios (en comparación con aproximadamente 1046K para D7 y 64K para D8). Eso es aproximadamente 40K menos en comparación con hace un año (a ese ritmo, tomará otros 3 a 4 años ...)".

(*) : este enlace también contiene muchos comentarios interesantes, como el primer comentario debajo , que es al igual que:

Por definición, se admite una versión en una página de proyecto cuando existen dos condiciones:

  1. el responsable del proyecto cree que es compatible.
  2. el equipo de seguridad está aceptando informes de problemas de seguridad y haciendo advertencias al respecto.

Eso es lo que el estado "compatible" significa y ha significado desde mayo de 2009 (y reiterado en mayo de 201 ).

Es por eso que el elemento 4 está en esta lista:

Todos Drupal 6 versiones en las páginas del proyecto se marcarán como no compatibles.

A partir del Drupal 6 EOL, el elemento # 2 ya no será cierto, por lo que tiene sentido marcarlos como no compatibles.

Esta publicación sobre la EOL es el resultado de numerosas conversaciones en los últimos 3 años sobre cuándo debería ser la EOL. Las personas que desean Drupal 6 y/o módulos contribuidos para recibir soporte por más tiempo.

2
Pierre.Vriens

Cuando sale una nueva versión Drupal), no se intenta hacer que las nuevas versiones sean "compatibles con versiones anteriores". Algunas cosas fundamentales cambiaron con Drupal 7, incluyendo el hecho de que lo que era el módulo "CCK" ahora es una característica en la funcionalidad central de Drupal. Entonces, una instalación de Drupal 7 no sabrá qué hacer con un Drupal 6 base de datos, a menos que siga el procedimiento de actualización recomendado . (Y aun así, si ha personalizado algún módulo o ha escrito sus propios módulos o plantillas, tendrá que trabajar un poco para convertir completamente la aplicación.)

Dicho esto, no, no tienes tienes para actualizar, al menos no ahora. Estás bien con Drupal 6 hasta que sale Drupal 8 sale, como otros han señalado. Puedes ejecutar un paralelo Drupal 7 servidor en una instalación MAMP o WAMP en su propio disco duro, y úselo para practicar la transferencia de su aplicación a Drupal 7. Una vez Drupal 8 sale, debería estar listo para actualizar su aplicación a Drupal 7 (y cualquier otro módulo que haya instalado debería haber alcanzado D7 para entonces).

1
JR Dixey