it-swarm-es.com

¿Cómo determinar si un paquete es seguro de desinstalar?

Sé que hay muchas recetas/estrategias para obtener un "Ubuntu mínimo", pero son demasiado extremas para lo que estoy tratando de hacer. Aún así, sospecho que tengo una tonelada de paquetes instalados que no necesito, ya sea directa o indirectamente.

¿Cómo puedo averiguar qué puedo eliminar? Como mínimo, necesito averiguar, para cada paquete instalado, si es necesario para cualquier "aplicación" que uso normalmente. (Por supuesto, hay "aplicaciones" que uso normalmente sin darme cuenta, por lo que es más fácil decirlo que hacerlo).

3
kjo

Tanto "seguro" como "mínimo" son muy, ¡muy relativo. Es imposible responder esta pregunta precisamente sin ser tú.

Si desea la instalación básica, instale buntu Minimal y agregue paquetes usted necesita a ese.

Si solo está preguntando qué puede eliminar sin eliminar todo el sistema, eso es bastante fácil de hacer con cualquiera de los frontales aptos más robustos como aptitude y synaptic. Seleccione un paquete para eliminar y la herramienta le dirá qué más debe hacer. Si eso no funciona para usted, simplemente revierta ese cambio.

Puedes eliminar el ubuntu-desktop paquete sin volcar el sistema y es probable que lo necesite para eliminar ciertas cosas. Si se queda atascado en un sistema en modo de texto, la reinstalación es la ruta más simple para la recuperación, pero deshacerá todo su trabajo.

Nuevamente, construir ¡arriba es más fácil que derribar ... Pero requiere que comprenda la pila con la que está trabajando.

Para graficar, puede usar algo como esto (requiere la instalación de graphviz e imagemagick):

apt-cache dotty ubuntu-minimal | dot -Tpng | display

Sin embargo, los gráficos son enormes. La representación lleva un tiempo.

4
Oli

He descubierto que Synaptic hace un trabajo creíble al identificar dependencias. Si selecciona cualquier paquete en particular, el botón de propiedades proporciona esto Synaptic Properties Page

Synaptic está disponible para instalar desde el Centro de software de Ubuntu

4
pfeiffep