it-swarm-es.com

Problemas con la tarjeta de video

mi portátil es HP ProBook 4530s-LH306EA. Tengo dos tarjetas de video discretas (AMD Radeon HD 6490M) e integradas.

Hoy he instalado Ubuntu 12.10 y encuentro el problema de que mi computadora se calienta mucho (júpiter muestra de 75 a 85 grados). Tengo entendido que el problema está en la tarjeta de video, por lo que he tratado de desactivarlo usando https://help.ubuntu.com/community/HybridGraphics Pero no sé cómo cambiarlo para siempre , porque después de reiniciar la computadora, el discreto se enciende.

Y no puedo entender por qué hay un problema tan grande con estas tarjetas de video. En Windows existe un programa, que sabe cuál de estas dos tarjetas de video usar.

PD: He omitido el paso con la copia de seguridad y empiezo a instalar, pero aparece un error: "No se pueden encontrar una o más herramientas necesarias para la instalación en el sistema. Instale las herramientas necesarias antes de instalar el controlador fglrx. Opcionalmente, ejecute el instalador con --force opción para instalar sin las herramientas. Forzar la instalación deshabilitará la aceleración de hardware de AMD y puede hacer que su sistema sea inestable. No recomendado. Consulte /usr/share/ATI/fglrx-install.log para obtener más detalles "

En el archivo de registro está escrito: "Compruebe si el sistema tiene las herramientas necesarias para la instalación. La instalación de fglrx requiere que el sistema tenga encabezados de núcleo. /Lib/modules/3.5.0-17-generic/build/include/linux/version.h no puede ser encontrado en este sistema ".

PSS He ejecutado con la opción --force y obtengo: Se detectó un adaptador compatible. Compruebe si el sistema tiene las herramientas necesarias para la instalación. La instalación de fglrx requiere que el sistema tenga encabezados de kernel. /lib/modules/3.5.0-17-generic/build/include/linux/version.h no se puede encontrar en este sistema. La instalación de fglrx se está forzando. La instalación continuará sin las herramientas necesarias en el sistema. Desinstalar cualquier controlador instalado previamente. Descargando el módulo radeon ... ERROR: Módulo radeon en uso Descargando el módulo drm ... ERROR: El módulo drm está en uso por radeon, i915, ttm, drm_kms_helper [Mensaje] Módulo Kernel: Intentando instalar un módulo kernel precompilado. [Mensaje] Módulo del kernel: la versión del módulo del kernel precompilado no coincide. [Error] Módulo Kernel: no se encontró el entorno de compilación del módulo Kernel; consulte el archivo Léame. [Reiniciar] Módulo Kernel: update-initramfs

1
kobra

Si no puede instalar/usar AMD Catalyst Driver (como yo) desde los repositorios de Ubuntu o manualmente desde su sitio web, puede activar automáticamente los gráficos discretos y apague cuando cambie entre fuente de alimentación de CA y batería simplemente agregando un pequeño archivo de script ejecutable llamado 11_hybrid_graphics_switch en la carpeta /etc/pm/power.d con los siguientes contenidos:

#!/bin/bash
if on_ac_power; then
    echo ON > /sys/kernel/debug/vgaswitcheroo/switch &
else
    echo OFF > /sys/kernel/debug/vgaswitcheroo/switch &
fi
exit 0

Para obtener más información, consulte mi respuesta en: Error al crear el archivo .deb del controlador AMD Catalyst

0
Sadi

Le sugiero que use AMD Catalyst Driver. Puede cambiar entre gráficos AMD o gráficos integrados gráficamente. Este es el enlace para el tutorial: BinaryDriverHowto/ATI . Lea la sección 3.2, espero que lo ayude.

0
oentoro