it-swarm-es.com

¿Cómo nombraría las funciones de importación y exportación en Java?

Tengo una clase Java que maneja la importación y exportación de datos. Comenzó como un simple

private void export() {
}
private void import() {
}

Por supuesto, primero escribí la exportación, la comprometí y luego pasé a escribir la importación. Pero importar es una palabra clave en Java - No puedo usar eso como nombre de función. Así que vuelvo y cambio el nombre de ambos métodos. Por lo general, termino con

private void doExport() {
}
private void doImport() {
}

que es feo y se siente artificial. ¿Qué piensas de estos nombres? ¿Tienes mejores sugerencias?

Nota: pregunto ahora, porque ahora ha sucedido tres veces y esa palabra clave se está volviendo bastante molesta.

6
configurator

Preferiría algo como esto:

private void importData(){}
private void exportData(){}

Si ahora usa esta clase como API, puede hacer algo como esto:

dataUtil.importData();

Con CodeCompletion del IDE, las diferencias son más visibles si estos métodos no se inician de la misma manera.

4
ckuetbach

Este es el mismo problema que con todas las palabras clave en los lenguajes de programación. Pero el problema es fácil, solo elige otro nombre.

¿Qué tal esto?

private void dataExport() {
}
private void dataImport() {
}
1
Jonas