it-swarm-es.com

¿OpenJDK6 todavía es compatible?

Yo uso OpenJDK6, pero ¿es necesario actualizar a OpenJDK7?

Parece que Oracle ha dejado de admitir Java 6 ...

Leí aquí que Red Hat proporcionará soporte para OpenJDK6: http://Java.about.com/b/2013/03/07/red-hat-assumes-leadership-of-openjdk-6.htm

¿Eso significa que Ubuntu continuará entregando actualizaciones de seguridad y correcciones de errores a OpenJDK6?

¿O tengo que actualizar ...

Estoy usando la versión actual de LTS

6
paed808

No hay indicios de que Ubuntu haya dejado de proporcionar soporte y actualizaciones de backport para JDK6.

A partir del 5 de marzo de 2013, Ubuntu todavía estaba enviando notificaciones de seguridad , junto con proporcionar los parches necesarios para las vulnerabilidades encontradas en Open JDK6.

Si bien Oracle ha finalizado el soporte para actualizaciones públicas, el equipo Open JDK6-dev ha declarado :

"Oracle finalizó las actualizaciones públicas de JDK6 a fines del mes pasado. Muchas personas parecen haber concluido que el proyecto OpenJDK6 terminará al mismo tiempo. Esto es incorrecto: OpenJDK6 continuará, pero será mantenido por la comunidad fuera de Oracle". "

  • ¿Qué pasa con las actualizaciones de seguridad?

"Los enviaremos de nuevo a medida que lleguen y los enviaremos a OpenJDK 6. Sin embargo, puede haber algún retraso debido al esfuerzo y las pruebas que requiere el puerto de retorno. Por lo tanto, si desea la versión más segura y actualizada de OpenJDK, debe actualizar a OpenJDK 7. También solucionaremos cualquier error de seguridad que se encuentre solo en OpenJDK 6, pero de nuevo puede haber algunos retraso. "

En este momento, las actualizaciones de seguridad se incorporarán a JDK6 siempre que haya una comunidad que lo admita. Presumiblemente, estos se incluirán en Debian y en Ubuntu.

Puede leer el hilo completo en los archivos de correo jdk6-dev de marzo de 2013 bajo el título: El futuro de OpenJDK6 .

2
Kevin Bowen

OpenJDK6 ya no es compatible con ubuntu si lo instaló al actualizar ubuntu, OpenJDK6 se actualizará a 7 intente instalarlo desde ppa o código fuente ¿por qué no instala OpenJDK7? tiene todo lo que necesitas para ejecutar programas escritos en Java6

1
MostafaJF