it-swarm-es.com

avahi-daemon registra / retira repetidamente el registro de dirección que causa fallas en la red

Estoy usando Ubuntu 15.10 usando una conexión Ethernet a mi enrutador modelo de cable. No he personalizado la configuración de red de ninguna manera después de instalar Ubuntu. Me di cuenta de que después de aproximadamente 12 a 24 horas después del arranque, Ubuntu comienza a desconectar las conexiones a Internet. Por lo general, noto esto después de que las páginas web no pueden cargar imágenes o archivos CSS. Cuando esto sucede, noto que el /var/syslog está lleno de entradas como esta:

Jan  8 05:26:40 46lbs avahi-daemon[730]: Registering new address record for 2605:e000:850e:8800:d9cb:5166:bac1:61d2 on eth0.*.
Jan  8 05:26:40 46lbs avahi-daemon[730]: Withdrawing address record for 2605:e000:850e:8800:d9cb:5166:bac1:61d2 on eth0.
Jan  8 05:26:43 46lbs avahi-daemon[730]: Registering new address record for 2605:e000:850e:8800:d9cb:5166:bac1:61d2 on eth0.*.
Jan  8 05:26:43 46lbs avahi-daemon[730]: Withdrawing address record for 2605:e000:850e:8800:d9cb:5166:bac1:61d2 on eth0.
Jan  8 05:26:46 46lbs avahi-daemon[730]: Registering new address record for 2605:e000:850e:8800:d9cb:5166:bac1:61d2 on eth0.*.
Jan  8 05:26:46 46lbs avahi-daemon[730]: Withdrawing address record for 2605:e000:850e:8800:d9cb:5166:bac1:61d2 on eth0.
Jan  8 05:26:49 46lbs avahi-daemon[730]: Registering new address record for 2605:e000:850e:8800:d9cb:5166:bac1:61d2 on eth0.*.
Jan  8 05:26:49 46lbs avahi-daemon[730]: Withdrawing address record for 2605:e000:850e:8800:d9cb:5166:bac1:61d2 on eth0.
Jan  8 05:26:52 46lbs avahi-daemon[730]: Registering new address record for 2605:e000:850e:8800:d9cb:5166:bac1:61d2 on eth0.*.
Jan  8 05:26:52 46lbs avahi-daemon[730]: Withdrawing address record for 2605:e000:850e:8800:d9cb:5166:bac1:61d2 on eth0.

Por lo general, puedo recuperar el uso normal de Internet desconectando la conexión por cable utilizando el icono de red en la barra de herramientas de Ubuntu y luego volviendo a conectar. Sin embargo, esto es problemático. Me gustaría mantener el avahi-daemon para propósitos de descubrimiento. ¿Alguien sabe cómo detener este comportamiento? Para el registro, aquí está la salida de mi ifconfig

eth0      Link encap:Ethernet  HWaddr 08:62:66:7c:ea:35  
      inet addr:192.168.0.4  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: 2605:e000:850e:8800:8729:2a19:e7c8:5738/128 Scope:Global
      inet6 addr: fe80::a62:66ff:fe7c:ea35/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:4638380 errors:0 dropped:9 overruns:0 frame:0
      TX packets:2164811 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:5378789738 (5.3 GB)  TX bytes:231746518 (231.7 MB)
      Interrupt:20 Memory:fb200000-fb220000 

lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:40049332 errors:0 dropped:0 overruns:0 frame:0
      TX packets:40049332 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:2898153546 (2.8 GB)  TX bytes:2898153546 (2.8 GB)
3
Paul D

Tuve el mismo problema y encontré tu pregunta al buscar la respuesta. También encontré esta pregunta en serverfault :

Si su servidor DNS que utiliza este servidor tiene un dominio .local, entonces avahi no funcionará. Ver http://avahi.org/wiki/AvahiAndUnicastDotLocal para más información sobre esto.

Cuando eliminé mi dominio .local de mi servidor DNS, el problema desapareció. Espero que tengas el mismo éxito.

1
fileinster