it-swarm-es.com

Después de la actualización a 16.10, Ethernet dejó de funcionar

Network Manager informa:

device not managed

Salida de Sudo lshw -C Network:

*-network DISABLED        
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: [email protected]:02:00.0
   logical name: enp2s0
   version: 15
   serial: 2c:60:0c:f6:97:a6
   size: 10Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.042.00-NAPI duplex=full latency=0 link=no multicast=yes port=twisted pair speed=10Mbit/s
   resources: irq:47 ioport:4000(size=256) memory:c4404000-c4404fff memory:c4400000-c4403fff
*-network
   description: Wireless interface
   product: QCA9377 802.11ac Wireless Network Adapter
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: [email protected]:03:00.0
   logical name: wlp3s0
   version: 30
   serial: 48:e2:44:46:07:ab
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=ath10k_pci driverversion=4.8.0-34-generic firmware=WLAN.TF.1.0-00267-1 ip=192.168.1.101 latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:53 memory:c4200000-c43fffff

Salida de nmcli d:

DEVICE  TYPE      STATE      CONNECTION             
wlp3s0  wifi      connected  FASTWEB*************** 
enp2s0  ethernet  unmanaged  --                     
lo      loopback  unmanaged  --   

Salida de ifconfig:

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<Host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 2487  bytes 383935 (383.9 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2487  bytes 383935 (383.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.101  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 2001:b07:6452:4630:d631:dc14:aa32:46e7  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::7932:6d1f:e49b:9b8d  prefixlen 64  scopeid 0x20<link>
        ether 48:e2:44:46:07:ab  txqueuelen 1000  (Ethernet)
        RX packets 29742  bytes 30300740 (30.3 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 22589  bytes 4019841 (4.0 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Salida de ip a:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope Host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope Host 
       valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 2c:60:0c:f6:97:a6 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 48:e2:44:46:07:ab brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.101/24 brd 192.168.1.255 scope global dynamic wlp3s0
       valid_lft 42392sec preferred_lft 42392sec
    inet6 2001:b07:6452:4630:d631:dc14:aa32:46e7/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::7932:6d1f:e49b:9b8d/64 scope link 
       valid_lft forever preferred_lft forever

¿Cómo puedo solucionar esto?

15
Carlo Gandolfo

Ejecuta esto en la terminal (luego reinicia):

Sudo touch /etc/NetworkManager/conf.d/10-globally-managed-devices.conf

Se solucionó un problema similar cuando actualicé Ubuntu de 16.04 a 16.10.

31
Waqas Ali
4
Damodar D.

Su dispositivo existe, pero el sistema se niega a administrarlo por cualquier motivo.

Para resolver esto, asegúrese de que su archivo /etc/network/interfaces no contenga una definición para su dispositivo Ethernet. En una terminal, ejecute los siguientes comandos:

Sudo cp /etc/network/interfaces /etc/network/interfaces.bak
Sudo nano /etc/network/interfaces

Elimine todas las líneas excepto estas tres (a menos que tenga una muy buena razón para dejar otras líneas allí):

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Luego, reinicie el Network Manager reiniciando o ejecutando el siguiente comando:

Sudo service network-manager restart

Alternativamente, puede habilitar la administración de todas las interfaces mediante Network Manager, pero tenga en cuenta que esto puede causar otros problemas relacionados con la red.

En /etc/NetworkManager/NetworkManager.conf, cambie cualquier línea que diga managed=false a esto:

managed=true

Asegúrese de reiniciar NetworkManager reiniciando o utilizando el comando anterior.

4
Kaz Wolfe