it-swarm-es.com

Pantalla negra en la tarjeta de arranque nvidia optimus

Cada vez que inicio mi pantalla aparece con una pantalla negra con el mismo texto que si presiono ControlAltF1. Mi tarjeta gráfica es una tarjeta Nvidia Optimus con Bumblebee. También a veces aparece "Este sistema se ejecuta en modo de gráficos bajos". A veces se iniciará, pero requiere varios reinicios duros.

Esta es la salida de lspci:

00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)  
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)  
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)  
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)  
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)  
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)  
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev ff)
6
Armoredspider

Primero, para acceder al terminal, inicie en modo de recuperación, luego seleccione Solicitud de root. Sin embargo, esto solo montará el disco en modo de solo lectura, así que haga esto:

mount remount,rw /

Esto vuelve a montar el sistema de archivos en modo rw. Luego, desinstala todas tus cosas de Nvidia haciendo esto:

apt-get remove --purge nvidia*

Intenta arrancar entonces. Si aún así no se inicia correctamente, sugiero hacer una copia de seguridad de sus archivos desde el indicador raíz y luego reinstalar el sistema. Si arranca, reinstale las cosas de Nvidia:

Sudo apt-get install nvidia-current

Esto debería arreglarlo. (Al menos, funcionó para mí cuando tuve estos problemas).

3
mszegedy

¿Intentaste eliminar todos los controladores especiales de nvidia?

  1. Arranque en modo de terminal a prueba de fallas o versión anterior del kernel (si existe)
  2. do Sudo apt-get remove nvidia-current
  3. reiniciar
  4. después del arranque, intente actualizar el sistema y reinstale cuidadosamente los controladores de nvidia.

si esto no ayuda, elimine todo el personal de nvidia por Sudo apt-get remove --purge nvidia-* Tuve un comportamiento similar después de la actualización del kernel con una tarjeta nvidia diferente y esto me permite resolverlo.

2
Dee

Tuve el mismo problema que tú, mira esto problema con el inicio de ubunt Después de instalar Ubuntu, solo instalo bumblee y ahora todo funciona bien.

Como saben, el problema proviene de un soporte incompleto para la tecnología optimus en Ubuntu.

1
Ramyad