it-swarm-es.com

¿Por qué obtengo "Los elementos no se pueden instalar o eliminar hasta que se repare el catálogo de paquetes"?

Soy nuevo en Ubuntu. No puedo instalar nada en el Centro de software de Ubuntu.

Simplemente sigue dándome Items Cannot be installed or removed until package catalog is repaired.

Si hago clic en reparar solo me da:

Package operation failed 
installArchives() failed: (Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 174380 files and directories currently installed.)
Unpacking libjpeg8:AMD64 (from .../libjpeg8_8d-1_AMD64.deb) ...
dpkg: error processing /var/cache/apt/archives/libjpeg8_8d-1_AMD64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libjpeg.so.8', which is also in package libjpeg-turbo8:AMD64 1.2.1-0ubuntu2
configured to not write apport reports
Errors were encountered while processing:
 /var/cache/apt/archives/libjpeg8_8d-1_AMD64.deb
Error in function: 
dpkg: dependency problems prevent configuration of printer-driver-hpijs:
 printer-driver-hpijs depends on libjpeg8 (>= 8c); however:
  Package libjpeg8:AMD64 is not installed.

dpkg: error processing printer-driver-hpijs (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of printer-driver-hpcups:
 printer-driver-hpcups depends on libjpeg8 (>= 8c); however:
  Package libjpeg8:AMD64 is not installed.

dpkg: error processing printer-driver-hpcups (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of hplip:
 hplip depends on printer-driver-hpcups (= 3.12.6-3.1); however:
  Package printer-driver-hpcups is not configured yet.

dpkg: error processing hplip (--configure):
 dependency problems - leaving unconfigured
2
Paul

Prueba esto.

Terminal abierto con Ctrl+Alt+t

Escriba lo siguiente: borrar la base de datos del paquete (en caso de que algunos de ellos estén dañados)

Sudo apt-get clean

Sudo apt-get autoclean

Sudo apt-get -f install

entonces corre

Sudo dpkg --configure -a

y ejecuta esto de nuevo

Sudo apt-get -f install

si obtienes algo como

0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

entonces falló. De lo contrario, puede intentar descargar los paquetes del Centro de software de Ubuntu

Por cierto, ¿marcó todas las opciones en Opciones de fuentes de software ?:

enter image description here

1
AFwcxx