it-swarm-es.com

No se puede actualizar Thunderbird

Recientemente instalé Thunderbird 3.1 de alguna fuente que no era los repositorios de ubuntu. No puedo recordar en este momento de dónde lo obtuve (creo que fue empaquetado como deb), pero tengo un problema cuando intenta actualizar automáticamente.

A diferencia de las versiones que administran sus actualizaciones a través de los repositorios, se supone que esta se actualiza cada vez que sea necesario, lo que parecía estar bien, pero cada vez que lo intenta, aparece un error:

Hay disponible una actualización de seguridad y estabilidad recomendada, pero no tiene los permisos del sistema necesarios para instalarla. Póngase en contacto con el administrador del sistema o intente nuevamente desde una cuenta que tenga permiso para instalar software en esta computadora. Siempre puede obtener la última versión de Thunderbird en: http://mozillamessaging.com/en-US/Thunderbird

¿Hay alguna forma de otorgarle a TB los permisos que necesita por debajo de abrirlo como root?

4
mlissner

No. La única forma de permitir que Thunderbird se actualice solo es iniciarlo como root, o encontrar otra fuente que construya Thunderbird de tal manera que pueda instalarlo completamente dentro de su propia carpeta de inicio.

Una mejor opción, si desea ejecutar aplicaciones de vanguardia, es tratar de encontrar a alguien haciendo compilaciones en un PPA de Launchpad. Estos pueden actualizarse a través del sistema Synaptic/Upgrade normal, lo que significa que no terminará con casos de esquina como este. Como sucede, el equipo de Mozilla mantiene un PPA de las versiones más nuevas de Firefox y Thunderbird , incluso los nightlies. Si instala Thunderbird 3.1 desde allí, debería ser dorado.

4
Benjamin Pollack

Acabo de actualizar. En la terminal de lanzamiento de Thunderbird:

Sudo Thunderbird

Luego se actualizó sin problemas

Buena suerte

Antonio

0
TwoTone