it-swarm-es.com

¿Hay alguna razón convincente para actualizar Ubuntu 8.04 (Hardy Heron)?

Tanto la instalación de mi escritorio como la del servidor están bien. ¿Me estoy perdiendo algo importante que haría que una actualización valga la pena?

10
Aviah Laor

La respuesta corta sería:

  • Servidor: no
  • Escritorio: tal vez

El viejo dicho "Si no está roto, no lo arregles". es especialmente cierto cuando se trata de servidores. Si bien actualicé mi servidor de 8.04 a 10.04, eso fue solo porque había un montón de bibliotecas nuevas que realmente quería. Excepto que 8.04 sigue siendo una versión sólida, y si no hay nada que explícitamente te falta, definitivamente creo que deberías quedarte con él.

En cuanto al escritorio, la elección es menos obvia. El nuevo 10.04 probablemente brindará una "experiencia de escritorio" más agradable y pulida. Además, notará muchas más mejoras en el software de escritorio incluido que lo que generalmente hace con los demonios de servidor típicos.

Aún así, su escritorio 8.04 está funcionando para usted y, si bien lo mismo probablemente se aplicará al escritorio 10.04, un cambio siempre conlleva el riesgo de que algo salga mal. Supongo que todo se reduce a lo oneroso/posible que sería para usted reinstalar el escritorio 8.04 en el peor de los casos.

16
andol

Sí, se realizó una gran cantidad de trabajo proactivo de seguridad entre Hardy y Lucid. Simplemente compare la lista características de seguridad . Por ejemplo, muchos defectos de seguridad que podrían explotarse en Hardy son, como máximo, una denegación de servicio en Lucid.

10
Kees Cook

Depende de cuáles sean tus necesidades. Ciertamente, en el escritorio es más probable que actualice porque las aplicaciones y características cambian cada vez más rápido.

Sin embargo, también el servidor tiene algunas actualizaciones nuevas que pueden cortar en ambos sentidos. Por ejemplo, php5 se ha actualizado a 5.3, que tiene muchas características nuevas muy relevantes para el lenguaje php (espacio de nombres, funciones mágicas para métodos estáticos en objetos, etc.). Sin embargo, muchas aplicaciones antiguas de php no son compatibles con php5.3. Por lo tanto, debe sopesar si alguna de sus aplicaciones anteriores se ve afectada y si necesita esas nuevas funciones.

4
txwikinger