it-swarm-es.com

"El intento de inicio de sesión falló" para la autenticación de puerta de enlace de TS (RD)

He estado usando TS Gateway para permitir el acceso remoto a nuestro personal durante algunos meses y todo ha ido bien. Los usuarios se conectan a un escritorio de servidor terminal tradicional o visitan nuestro sitio web e inician una aplicación TS RemoteApp; en ambos casos, la conexión se enruta a través de una puerta de enlace TS.

Sin embargo, llegué al trabajo esta mañana y descubrí que ha dejado de autenticar usuarios a través de TS Gateway, y cada vez devuelve "El intento de inicio de sesión falló" como se ve en la imagen a pesar de que las credenciales son correctas.

alt text

Cabe señalar que todo funciona bien si el Gateway se saca de la ecuación, es el componente TS Gateway el que está causando estos problemas.

Los usuarios experimentan este problema ya sea que se conecten a través de XP SP3, Vista o 7.

En el servidor, aparecen un total de 4 entradas en el registro de seguridad de Windows exactamente a la misma hora por cada intento fallido de inicio de sesión: dos mensajes 4624 "Una cuenta se inició sesión correctamente" para el usuario, seguidos inmediatamente de dos mensajes 4634 "Se registró una cuenta apagado "s. Esto sugiere que el servidor acepta las credenciales como correctas y luego inicia al usuario. No se registra nada en absoluto en los registros de NPS y Terminal Server.

Un reinicio no cambia las cosas. Tampoco la eliminación y reinstalación por completo de las funciones de NPS y Terminal Server. Estoy desconcertado de cómo esto puede suceder de repente sin previo aviso.

Cualquier sugerencia será muy apreciada.

6
user2059

Este problema me ha estado atormentando durante meses en una máquina SBS 2008, pero nunca ha sido lo suficientemente crítico como para tomar medidas locas para solucionarlo.

Después de recurrir a desinstalar y reinstalar el servicio TS Gateway y aún no funciona, fui a IIS Administrador → Sitios → Aplicaciones web SBS → Rpc → Autenticación y encontré que solo la "Autenticación básica" estaba habilitada.

Aunque los detalles sobre este error en particular son escasos en línea, he visto que Outlook Anywhere parece cambiar IIS Esquemas de autenticación. Ya que esto es SBS, pensé que Exchange y TS Gateway podrían estar peleando por la configuración de autenticación .

Activé la "Autenticación de Windows" y luego ejecuté un IIS restablecer. Cuando IIS volvió a estar en línea, pude conectarme a través de TS Gateway a dos servidores y al menos una estación de trabajo. Me conecté y desconecté varias veces y no tuvo problemas.

No puedo garantizar que esto sea permanente, pero definitivamente lo espero.

EDITAR: Desde que hice este cambio, no he tenido ningún problema con TS Gateway.

5
Stephen Jennings

Ok, aquí está la respuesta?

2k8r2 y iis7

TSGateway solicita credenciales repetidamente pero no inicia sesión ...

Resulta que TSGateway no realiza la conexión ni la autenticación, IIS sí. Sorpresa, ya sé ...).

TSGateway solo filtros y rutas.

Entonces, ahora, ¿qué parte de IIS hace la conexión y autenticación para TSGateway? No lo sé. Y aparentemente, nadie más lo hace tampoco. Pero si se mete con la configuración de autenticación de RDWEB, RPC, RPCWCERT, SITIO WEB predeterminado, Authdiscover, puede hacer que funcione ...

Este es un buen artículo. Pero como puede ver, también es un tiro en la oscuridad con ellos.

NOTA: Aparentemente, la redirección del sitio web predeterminado interrumpe la comunicación con RDWeb y, por lo tanto, con TSGateway.

HTTP: redireccionamiento HTTPS…

Parece que mi sitio web predeterminado viene como HTTP, pero quería que los usuarios de HTTP pudieran acceder a él. Así que creé un sitio web de redirección para redirigir las solicitudes HTTP al sitio web predeterminado como HTTPS. Lo que funciona muy bien, pero detuvo mi autenticación TSGateway. (Creo que fue porque el sitio web de redireccionamiento estaba usando el puerto 80. Y por alguna razón, RDWEB usa el puerto 80 y el 443 para las comunicaciones ...)

Por cierto, si desactiva Requerir SSL en Configuración SSL en el sitio web predeterminado en IIS, funciona correctamente y hace lo mismo ...

De todos modos, comience a comprar para que RDWEB funcione correctamente y luego, trabaje en TSGateway.

RDWEB solo debe tener: Autenticación anónima habilitada La detección automática debe tener la autenticación anónima, básica y de Windows habilitada. OWA: solo básico. RPC: debe tener: Autenticación básica y de Windows. RPCWCert: No debería tener nada habilitado. Al menos, esos son los ajustes en Mi configuración ...

Buena suerte.

Robert

3
user58482

Tuve un problema similar. Descubrí que tenía que editar IIS Administrador → Sitios → Aplicaciones web SBS → Rpc Con Cert → Autenticación y agregué Autenticación de Windows. Luego realicé e IISRESET y todo funcionó como debería.

1
Mark D. MacLachlan

Tenía exactamente los mismos problemas que la publicación original. También estaba redirigiendo el sitio web predeterminado a/RDWeb/Pages/en-US, una vez que eliminé esa redirección, todo funcionó con normalidad.

Estoy desconcertado de cómo esto causó el problema con toda honestidad.

1
user56173

El servicio de Windows Terminal Services Gateway seguía fallando.

En ausencia de algo útil en los registros de eventos, solo consigo que el programador de tareas "net start tsgateway" unas cuantas veces cada hora. Horrible, pero sin quejas desde entonces.

1
tomfanning

Tuve un problema similar. La pantalla de inicio de sesión de Gateway seguía apareciendo. Los registros de seguridad del servidor mostraban un inicio de sesión de privilegios especiales, un inicio de sesión y un cierre de sesión para cada intento. Los registros de la puerta de enlace no mostraban nada.

Después de probar todo, noté que el área en la parte inferior de la pantalla de inicio de sesión de la puerta de enlace que debería mostrar el dominio estaba en blanco. Agregué el dominio a la pantalla de inicio de sesión del nombre de usuario: dominio\nombre de usuario y listo, todo funciona como debería.

Eso fue una pérdida de aproximadamente 4 o 5 horas de mi vida buscando soluciones y probando arreglos complicados ... Espero que le ahorre a alguien más algo de tiempo ...

1
Brian

El mismo problema para mí también, SBS2008 de repente comenzó a informar "error de inicio de sesión" cada vez que se utilizaba TS Gateway. Encontré que el sitio RPCwithCert en IIS no tenía método de autenticación, marcó Autenticación de Windows y ahora funciona de nuevo ....

0
Giles Conn

Tenía un ticket de soporte de MS, así que les pedí que miraran esto. ¡Simplemente cambiaron Outlook en cualquier lugar a NTLM y VIOLA!

0
Mark M

Para mí, lo configuré todo para SSO, luego hice algunos cambios y se rompió. Podía ingresar al sitio de RemoteApps, pero cuando intentaba iniciar una aplicación, se me solicitaban mis credenciales y "el intento de inicio de sesión falló" en la parte inferior de la ventana de inicio de sesión. Gracias a la publicación de Robert desde arriba, descubrí que era la redirección que puse en IIS7. Mi configuración es un servidor que actúa como puerta de enlace, agente y acceso web. Dejé todo para que se ejecutara en "Sitio web predeterminado". Para ampliar la publicación de Robert, dejé la redirección en su lugar, pero marqué "Solo redireccionar solicitudes al contenido de este directorio (no subdirectorios)", ya que quiero que las solicitudes al sitio raíz lleguen a RDWeb y esto funciona perfectamente para mí.

0
Fuzzball