it-swarm-es.com

XFCE, TTY, pantalla en blanco, atajos que no funcionan

Tengo un extraño problema con los atajos de teclado. Después de encender mi computadora (o reiniciar) e iniciar sesión, los accesos directos no funcionan. Para que funcionen, tengo que cerrar sesión e iniciar sesión nuevamente. Entonces todo está bien. Hay otro problema Tengo acceso a TTY-s 1-6 solo después de reiniciar (e iniciar sesión por primera vez). Cuando cierro la sesión (para que los accesos directos de Xfce funcionen), pierdo el acceso a mis TTY-s. Hay una pantalla en blanco en su lugar.

Creo que puede haber un conflicto clave. Pero no uso ninguna combinación de atajos que use CTRL+ALT al mismo tiempo. Tengo una tarjeta gráfica NVIDIA.

Pongo una línea:

Option "HandleSpecialKeys" "always"

en la sección "ServerLayout" (lo intenté antes en ServerFlags) en /etc/X11/xorg.conf pero no me ayudó (en primer lugar, quería arreglar ttys, sin ser consciente del problema de los accesos directos del escritorio)

Un problema con la pantalla en blanco CTRL+ALT+F1-F6 sucede también después de despertarse de un estado suspendido. Para obtener acceso a TTY 1-6 después de perderlo, tengo que reiniciar mi computadora.

Gracias por cualquier idea.

2
MikeD

Ok, descubrí cómo hacer que los TTY-s funcionen después de una suspensión, inicio de sesión, etc. En primer lugar, pensé que la razón es el Power Manager. En realidad, la razón fue bastante diferente. La instalación de xserver-xorg-video-nouveau y los paquetes conectados, en lugar del controlador NVidia Current, ayudó. Tenía el controlador Nvidia versión 304, y no estoy seguro acerca de la nueva versión, 310; si es mejor o no En cuanto a los atajos, también he reemplazado en mi archivo de atajos de teclado (/home/mpd/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml) todas las entradas de "Control" con "Primario".

2
MikeD